You must Sign In to post a response.
  • Category: ASP.NET

    Autocomplete not working with master page

    i'm tried to develop smal auto complete task with master page but it's not working.but i'm writting code in without master page it's working.please help me friends and save my time.
  • #769342
    Hi Sadiq,

    Make sure you are referring all the JS or external files for the same in your master page as well. Or please check ur browser console perhaps there is some error. You might be missing some reference in Master page

    Anjali Bansal

    ~Give your best and lead the world

  • #769344
    Hi Sadiq.

    This will be problem in render scripts in master page most probably. Check whether you are trying to use same js file but with different versions.
    In your content page and master page there is a reference to file with different versions.
    Try to load the reference js file either from content page or from master page do any one.
    You can get desired out put if you remove the below scripts from your master page

    //remove or comment below scripts in master page which are already in your content page

    Sridhar Thota.
    Editor: DNS Forum.

  • #769365
    Can you please share how you are using AutoComplete. If you mean Ajax AutoCompleteExtender control or jQuery AutoComplete.
    Code for Ajax AutoCompleteExtender control would be somewhat like,

    <asp:TextBox ID="txtVehicleNo" runat="server" ToolTip="Enter Vehicle Number (Full)"
    <asp:AutoCompleteExtender ID="txtVehicleNo_AutoCompleteExtender" runat="server" DelimiterCharacters=""
    Enabled="True" ServiceMethod="GetVehicleList" ServicePath="" TargetControlID="txtVehicleNo"
    UseContextKey="True" MinimumPrefixLength="2">

    Refer to
    for complete source code and implementation of this control.
    If you mean jQuery AutoComplete, try solution by Shridhar and note that Putting jQuery reference in your MasterPage or contentpage header as first JS file may help.

    Glad to be,
    John Bhatt
    Editor - DNS Forums

  • Sign In to post your comments