You must Sign In to post a response.
  • Category: WCF

    Hosting WCF service in IIS

    Hi All,

    I configured a WCF service in IIS (Client machine). But i am getting "page not found" error. I tried in both the ways like check it in Internet explorer with url like (http://localhost/service name/pagename.svc) and as well as
    inside IIS -> Web site -> right click -> browse . Both the cases getting same error like "Page Not found".

    My WCF service is not a developped .NET code. its a built in package service from third party vendor. so i can't set any configuratios or frame work from program side.

    Client machine have windows 2003 server and IIS 5.2 with Frame work 1.1 .configurations seems old.
    Is the .NET frame work 1.1 is the issue for this. Do we need 3.5 for working WCF service in IIS? or do we need greter than 6 IIS version?

    Please help me on this. my work is struck here and i am not able to move further on this.

    Your reply will help me great.
    Thanks in advance.
  • #758800

    Try below things
    1.Check that the isapi.dll is pointing to v2.0

    2.In command prompt run the following command
    aspnet_regiis.exe -i –enable

    3.Restart IIS.

    4.Run the below command
    Communication Foundation
    ServiceModelReg.exe -i


    DNS Member.
    "Hope for the best.. Prepare for the worst.."

    Sridhar Thota.
    Editor: DNS Forum.

  • #758806

    You can deploy WCF Service manually by following the below steps:
    1. Click Start\Run and type 'inetmgr' (assuming you already have IIS installed)

    2. Right click sites, and add a new site. In my case, I created the BookStore site. I created the physical path C:\inetpub\wwwroot\Bookstore

    3. I then created a subdirectory for web services. C:\inetpub\wwwroot\Bookstore\Services and a bin folder to put the binaries in that you just compiled. You should end up with a directory structure like this: C:\inetpub\wwwroot\<yoursite>\Services\bin.

    4. Copy the DLLs from your services bin\debug or bin\release folder to the …\<yoursite>\Services\bin folder.

    5. Copy the web service's .svc and web.config files into the …\<yoursite>\Services folder. If your service has any additional files that it needs to function, copy them to that folder as well. The Book Store example needed a .txt file for its data.

    6. In the IIS Manager, create a new application for your services folder. Do this by right-clicking the Services folder and select, "Convert to Application". Select your newly created Services folder for the physical folder and click OK. Make note of the application pool that you selected.

    7. Change the application pool's advanced settings to select the .NET Framework 4.0 (assuming you're using 4.0 – if not be sure the right version of .NET for you is selected).

    8. Grant access to the application pool identity to your file folder. The identity that you select will be IIS AppPool\<AppPoolName>.In my case it was IIS AppPool\BookStore. Be sure to grant it Read & execute, List folder contents, and Read.

    <- If you happen to miss this step, IIS cannot load your service assemblies. ->

    9. That's it! To test your service, you should be able to select the .svc file in the IIS Manager and click Browse and get a screen that describes your service.

    Hope this will help you.
    Mark the answer if it helped you.

    Nirav Lalan
    DNS Gold Member
    "If you can dream it, you can do it."

  • #758807
    How can you run WCF with the framework 1.1, you need to atleast set it beyond framework 2.0+.
    Try to set the framework as 3.5 and try to use IIS 6+, do not use IIS 5.1
    for Hosting and Consuming WCF Services here are the basic prerequisite, you atleast need following things with you,
    - Microsoft .NET Framework 3.0
    - Windows Vista
    - Microsoft Internet Information Services
    - Microsoft Visual Studio 2005

    Editor, DotNetSpider MVM
    Microsoft MVP 2014 [ASP.NET/IIS]

  • #758819
    Hi Sridhar,

    i did what ever you mentioned in your post. And even now i installed 3.5 frame work as well. Removed earlier WCF website and re created newly. But still getting same error. I don't have any other clue.

    Do you think any other options needs to do or am I missing anything?

    Please help me.


  • #758865
    Hi All,

    Still the error is same. itsWindows 2003 server and IIS 6.

    At the front view its showing page not found error. When i verified in EventViewer its not throwing any exception. No Error in EventViewer as well. When i verified IIS logs it's showing something called "Connection_Dropped DefaultAppPool".

    If any one have idea about this error please help me .

    Thanks In Advance.

  • #758866

    You can refer the below site for this error:

    Hope it will help you to solve your problem.

    Nirav Lalan
    DNS Gold Member
    "If you can dream it, you can do it."

  • Sign In to post your comments