You must Sign In to post a response.
  • Category: Sharepoint

    Multiple spgridview sorting issue in sharepoint 2010 webpart

    Hello,

    In my sharepoint custom webpart i am using two spgridviews, here sorting of the second spgridview is not working , it is always sorting the first spgridview if we sort the second one also.Even the filtering functionality for both the spgridviews are working.

    Kindly help.

    Thanks
  • #749991
    Hai Ginnas,
    By looking out your description details, it seems that due to the post back, its always working for the first GridView and not for the second GridView. So you can just try to use the JavaScript for the Sorting and then it should work fine.
    Hope it will be helpful to you.

    Regards,
    Pawan Awasthi(DNS MVM)
    +91 8123489140 (whatsApp), +60 14365 1476(Malaysia)
    pawansoftit@gmail.com

  • #750012
    Hi Ginnas,

    Agree with Pawan. Just check the postback property. Due to this itself the second gridview sorting may not be working.

    Thanks,
    Ashutosh Jha
    http://tricksroad.com

  • #750074
    Hi ginnas,

    We can't able to decide what is the exact issue on here better to put a break point and check line by line then you can easily identify the issue where it's get st-rucked exactly.

    --------------------------------------------------------------------------------
    Give respect to your work, Instead of trying to impress your boss.

    N@veen
    Blog : http://naveens-dotnet.blogspot.in/


  • Sign In to post your comments