You must Sign In to post a response.
  • Category: .NET

    How to solve this hosting Issues

    Hi

    When i hosted to server in my asp.net project . I meet this error

    Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

    How to fixed this . I set also in IIS anonymous -> Enabled but not working.
    give me solution any one.
  • #768143
    Hi,

    @Whether is prompt for User Name and Password which should provide in Connection String?
    @Have you set the Integrated Security=false
    @ Also check the below are disabled.
    Anonymous Authentication = Enabled
    ASP.Net impersonation = Disabled
    Windows Authentication = Disabled

    Thanks,
    Mani

  • #768150
    The problem has many causes and multiple solution you can try with the followings workarounds
    - You probably just need to provide a user name and password in your connectionstring and set Integrated Security=false
    - if u use sql server for website,need to SQL Server Authentication,dont use Windows Authentication.Try to give username ,password and providerName="System.Data.SqlClient".
    Try to correct datasource in connectionString in web.config file
    - The problem is may due to 'authentication mode="Windows"' I think you need to impersonate the website to get resolved this error
    see below tags that needs to be add in web.config under system.web

    < identity impersonate="true" password="xxxxxx" userName="xxxxxxx" />


    hope it helps

    Thanks
    Koolprasd2003
    Editor, DotNetSpider MVM
    Microsoft MVP 2014 [ASP.NET/IIS]


Sign In to post your comments