You must Sign In to post a response.
  • Category: .NET

    How to Fixed this service issue

    Hi
    I have install xampp then

    I try to start apache service in services.msc but i meet following error any one guile me.

    Windows could not start the Apache2.2 on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 1
  • #767411
    Hi,
    It is because there are some other programs listening on port 80 like:
    1.Skype (Port 80)
    2.Antivirus (Port 80)

    You can shutt down the program's using port 80
    or
    Configure them to use a different port
    or
    Configure Apache to listen on a different port with the Listen directive in httpd.conf.

    Check PID's by typing this CMC command:
    C:\Users\UruserName>netstat -ao -p tcp

  • #767416
    Are you using IIS and Apache in the same system. Basically IIS will use the port 80. It will not allow other application to use the same port. If you try to run the "Apache" in the same system. Apache can not access the port 80. So the service will get fail. So you can run the IIS in port 80 as default and you can change the Apache port number.

    In the Apache {Tomcat installation folder}\ conf \server.xml, you can change the port

    By Nathan
    Direction is important than speed

  • #767417
    If you are using "apache 3 " you can edit the config fine "apache2/ports.conf" and change the port into different port "Listen 8080"

    If you are using XAMP then edit "G:\xampp\apache\conf\httpd.conf" and change the port number "Listen 8080"

    By Nathan
    Direction is important than speed

  • #767421
    Hai Kumar,
    Looks like you are already running some other application on the same port using HTTP. HTTP works on the port 80. So if you already have any other application on the same port then stop and use the same port for aws and then it will work.
    Hope it will be helpful to you.

    Regards,
    Pawan Awasthi(DNS MVM)
    +91 8123489140 (whatsApp), +60 14365 1476(Malaysia)
    pawansoftit@gmail.com

  • #767436
    Basically aapache uses port 80 and there are many software installed on machine that you need to disable I think most of the time
    There is some other program listening on port 80, usual suspects are
    1.Skype (Listens on port 80)
    2.NOD32 (Add Apache to the IMON exceptions' list for it to allow apache to bind)
    3.Some other antivirus (Same as above)
    Way to correct it is either shutting down the program that's using the port 80 or configure it to use a different port or configure Apache to listen on a different port with the Listen directive in httpd.conf. In the case of antivirus configure the antivirus to allow Apache to bind on the port you have chosen

    Thanks
    Koolprasd2003
    Editor, DotNetSpider MVM
    Microsoft MVP 2014 [ASP.NET/IIS]


Sign In to post your comments