You must Sign In to post a response.
  • Category: WCF

    Methods are not being exposed in wcftestclient

    Hi Folks,


    Please help me out with this..methods are not being exposed in WCFTestClient..Please find below Web.config...

    <?xml version="1.0"?>
    <configuration>

    <appSettings>
    <add key="aspnet:UseTaskFriendlySynchronizationContext" value="true" />
    </appSettings>
    <system.web>
    <compilation debug="true" targetFramework="4.5" />
    <httpRuntime targetFramework="4.5"/>
    </system.web>
    <system.serviceModel>

    <services>
    <service name="SimpleRESTServiceCRUD.BookService" behaviorConfiguration="bookServiceBehavior" >
    <endpoint address=""
    binding="webHttpBinding"
    contract="SimpleRESTServiceCRUD.IBookService"
    behaviorConfiguration="RESTEndpointBehavior" />
    </service>
    </services>
    <behaviors>
    <endpointBehaviors>
    <behavior name="RESTEndpointBehavior">
    <webHttp/>
    </behavior>
    </endpointBehaviors>
    <serviceBehaviors>
    <behavior name="bookServiceBehavior">
    <!-- To avoid disclosing metadata information, set the values below to false before deployment -->
    <serviceMetadata httpGetEnabled="true" httpsGetEnabled="true" />

    <!-- To receive exception details in faults for debugging purposes, set the value below to true. Set to false before deployment to avoid disclosing exception information -->
    <serviceDebug includeExceptionDetailInFaults="false" />
    </behavior>
    </serviceBehaviors>
    </behaviors>
    <protocolMapping>
    <add binding="basicHttpsBinding" scheme="https" />
    <add binding="mexHttpBinding" scheme="http"/>
    <add binding="mexHttpsBinding" scheme="https"/>
    </protocolMapping>
    <serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true" />

    </system.serviceModel>
    <system.webServer>
    <modules runAllManagedModulesForAllRequests="true" />
    <!--
    To browse web app root directory during debugging, set the value below to true.
    Set to false before deployment to avoid disclosing web app folder information.
    -->
    <directoryBrowse enabled="true" />
    </system.webServer>

    </configuration>



    thanks,

    sam
  • wcftestclient (344640-1-wcftestclient.zip)
  • #766281
    Hi
    Have you marked your methods with[OperationContract] attribute and method should be public to expose this into wcftestclient.

    /hope it will help

    Thanks
    Umesh Bhosale


  • Sign In to post your comments
    Submit New Thread
    Return to Return to Discussion Forum