You must Sign In to post a response.
  • Category: ASP.NET

    Waiting for localhost

    I hope someone can help me because I run out of thing to try to fix my issues.
    When running any MVC or Web API project in IIS Express resulting in IE being open and message "Waiting for localhost" and page never loads.
    Also the Global.asax.cs is Application_Start method is never hit.
    My environment is Windows 10 Pro
    I'm using VS 2015 (but same problem happens to VS 2013)
    Here is what I have tried so far:
    • Uninstalled and re-installed IIS and IIS express 10
    • Uninstalled and re-installed VS 2015
    • Tried same solution on another PC works just file in.
    I have also mention that my problems I thing started after I installed node.js. I have remover node.js but still can't run my MVC APP in IIS Express.
    Any advice would be appreciated.
    Thank you.
  • #765589
    Hi,

    Almost sounds like the database connection is going off neverland.

    If your timeout on the connection and/or command is set pretty high, like 300 (which is 5 minutes) then it would appear to just hang forever if it is unable to make that connection.

    The first thing I'd try is to set the connection timeout to something reasonable like 15 seconds in the web.config.

    Then I'd run it again.

    Assuming you get a connection failure, I'd use another tool to try and connect to the database using the settings in your web.config.

    Hope it helps!!

  • #765591
    Hi,

    As per my investigation in Google, I found the root cause problem of this issue is "Authentication" fails in Windows level, they are following several steps to resolve this I will share you those, request you to kindly check and try it in your case.

    1) UnInstall VS 2015 and repair VS 2013, then you will get the credentials exactly,

    refer below link
    http://forums.asp.net/t/2064758.aspx?Waiting+on+localhost

    2) Still you are suffering to resolve the issue, then try to get the Administrator logins for your IIS, check with your IIS Administrator for this issue.

    refer below link
    http://stackoverflow.com/questions/5704780/waiting-for-localhost-forever

    Hope this will helpful to you...

    --------------------------------------------------------------------------------
    Give respect to your work, Instead of trying to impress your boss.

    N@veen
    Blog : http://naveens-dotnet.blogspot.in/

  • #765619
    I have observed mot of the time first event/load will take much time as there are number of formalities that IIS needs to finish, I think you need to WAIT for some more time to finish the process, Put a debugger on Application_start event in global.asax
    Thanks
    Koolprasd2003
    Editor, DotNetSpider MVM
    Microsoft MVP 2014 [ASP.NET/IIS]


Sign In to post your comments