You must Sign In to post a response.
  • Category: ASP.NET

    server signature problem

    how to turn off server signature using asp .net windows server
    i use <httpRuntime enableVersionHeader="false" /> and
    <system.webServer>
    <httpProtocol>
    <customHeaders>
    <remove name="X-AspNet-Version" />
    <remove name="X-AspNetMvc-Version" />
    <remove name="X-Powered-By" />
    <!-- <remove name="Server" /> this one doesn't work -->
    </customHeaders>
    </httpProtocol>
    </system.webServer>
    but the same error appearing on seocheckup
  • #765074
    Hi
    Can you elaborate your issue


    Refer this urls below i mentioned

    "ask.xmodulo.com/turn-off-server-signature-apache-web-server.html"

    "nixtechnica.blogspot.in/2007/05/how-and-why-to-disable-apache-server.html"

    "unixmen.com/how-to-disable-server-signature-using-htaccess-or-by-editing-apache/"


    "htaccess-guide.com/changing-server-signature/"

    Name : Dotnet Developer-2015
    Email Id :kumaraspcode2009@gmail.com

    'Not by might nor by power, but by my Spirit,' says the LORD Almighty.

  • #765075
    "Your server signature is on. Turning off your server signature is generally a good idea from a security
    standpoint."
    this is problem when i doing seo work on my website,i want to avoid this problem to improve seo score.
    i am using windows server,how can i avoid this,i cant use .htacess file

  • #765079
    Attackers can use server signature to their advantage when performing an attack that why it is always advisable to disable server signature
    if you are doing SEO work then it will always give you such exception, I think you need to disable them using below link
    http://www.unixmen.com/how-to-disable-server-signature-using-htaccess-or-by-editing-apache/

    Thanks
    Koolprasd2003
    Editor, DotNetSpider MVM
    Microsoft MVP 2014 [ASP.NET/IIS]


Sign In to post your comments