You must Sign In to post a response.
  • Category: Webservices

    Web Service not accessing

    Hello.
    I have created 1 web service with named pipe.
    I hosted / published it on local machine IIS. It works.
    But when I host and publish same on remote machine (any other server).
    Its not working for me.
  • #763824
    First check if ASMX is accessible from remote machine, try to put address in browser and see if you can see our methods that you have written in web service
    http://IPaddress/test/webservice1.asmx
    If it is properly accessible then check for the web reference in your application

    Thanks
    Koolprasd2003
    Editor, DotNetSpider MVM
    Microsoft MVP 2014 [ASP.NET/IIS]

  • #763826
    Hi Pranjal.

    As prasad said, you need to check whether the service methods are getting accessed in your service.asmx file.
    Kindly post the code which you have used for creating instance of proxy class in order to access the service methods.
    Adding web reference is the key thing to be done.
    Make sure the server is in running state while the client application is accessing the service methods.

    Sridhar Thota.
    Editor: DNS Forum.

  • #763830
    Some of the tips

    1. Are you able to access the particular server from your box check that first.

    2. Try to access url in that server it self whether it is working or not?

    3. Check any firewall roles blocking that server url

    By Nathan
    Direction is important than speed

  • #763847
    Hai Pranjal,
    Are you trying to access the service using remote machine?? It should be accessed via browser.
    Please check the below link and match with your code to access the named pipe server:

    http://www.codeproject.com/Tips/855861/NET-Interprocess-Communication-using-Named-Pipe

    Hope it will be helpful to you.

    Regards,
    Pawan Awasthi(DNS MVM)
    +91 8123489140 (whatsApp), +60 14365 1476(Malaysia)
    pawansoftit@gmail.com


Sign In to post your comments