You must Sign In to post a response.
  • Category: WCF

    Webapi session working in ie but null in googleChrome

    Hi,i am working on webAPi controller,
    after login,i have stored HttpContext.Current.Session["UserName"] ="Somevalue";
    after redirericted into another controller,
    its available in InternetExplorer,but its null in GoogleChrome
  • #761848
    It is not depending on your code. There may be an issue to handle session/cookies in the chrome.

    You can try to access from another system. If it is working fine. you can try the following!topic/chrome/qn8dpw8V9Yc

    By Nathan
    Direction is important than speed

  • #761852

    Have you tried in other browser apart from IE and Chrome?
    In chrome go for content settings and make sure the allow local data to set radio button is selected.


    Sridhar Thota.
    If you learn't from defeat..
    You haven't really lost..

    Sridhar Thota.
    Editor: DNS Forum.

  • #761862
    Go to Settings in Google Chrome Browser -> click on Show Advanced Settings -> Content Settings -> Make sure that "Block Sites from setting any data" option is unchecked. Instead select the "Allow local data to be set(recommended)"
    Miss. Jain
    Microsoft Certified Technology Specialist in .Net

    Delete Attachment

  • #761943
    Hello Ramana,

    Mr. Sridhar and Vaishali are right.

    If you are setting recommended options in chrome than there will be no problems as per my experience.

    Happy coding.

    Nirav Lalan
    DNS Gold Member
    "Failure is the path of least persistence"

Sign In to post your comments