You must Sign In to post a response.
  • Category: ASP.NET

    RDLC report not run on server

    We are trying to deploy a web application on a server. Everything works except for the RDLC reports. When we try to run one, we get a 'The page cannot be found' error.

    There reports work on my computer (Vis Studio 2010) , but not on the server. The difference is that my computer has Vis Studio 2010 installed. The server does not.
    how it fix? Please help.

    Many thanks
  • #751221
    Hello kapil,

    First check all pages url those must be correct
    Check report path it must correct.
    Now you have to put following dlls in your project bin folder.
    1) Microsoft.ReportViewer.WebForms.dll
    2) Microsoft.ReportViewer.Common.dll
    3) Microsoft.Web.Infrastructure.dll
    4) Microsoft.ReportViewer.Common.dll
    5) Microsoft.ReportViewer.ProcessingObjectModel.dll

    I hope this will help you, if still you have an issue i'll get back to you.

    Regards,
    Nirav Prabtani (Senior Web Developer)
    Email : niravjprabtani@gmail.com
    blog : niravprabtani.blogspot.in

  • #751251
    Yes , the error is missing of some assemblies, Please do the below steps to fix the issue.

    Please try to install Crystal Reports for .NET on the server. The setup package is in your Visual Studio 2005 installation directory. For example, I installed vs.net 2005 in d:\vs.net2005. The setup package (CRRedist2005_x86.msi) should exist in this directory: D:\vs.net2005\SDK\v2.0\BootStrapper\Packages\CrystalReports. Copy the files to the server and then install it.

    when i tried in google i got these reasons also. Please make it sure below things.

    Have you made sure you configure your Crystal Report properly? Few things to check:
    1. Please make sure the CR installed on the system matches the CR used on your site
    2. Please make sure the assemblies used on your web.config matches the assemblies installed on your system
    3. Please make sure the FULL TRUST option is enabled on your site
    4. Please make sure your CR site is running under LOCAL SERVICE permission
    5. Please make sure you copy the aspnet_client and crystalreportviewer folders to your operating folder.

    Please mark it as answer if its satiesfies else let us know we are happy to help.

    Rajesh B
    To Live More,Learn More

  • #751257
    Hello Rajesh, thanks for your answer i don't install Visual studio on server. plz give another option.

  • #751259
    Hi Nirav, I found
    1) Microsoft.ReportViewer.WebForms.dll
    2) Microsoft.ReportViewer.Common.dll
    3) Microsoft.ReportViewer.Common.dll

    at
    Program Files\Microsoft Visual Studio 10.0\ReportViewer

    but i am not able to finding
    3) Microsoft.Web.Infrastructure.dll
    5)Microsoft.ReportViewer.ProcessingObjectModel.
    dll

    Can you please tell me where they are located.
    Thanks for your answer.

  • #751329
    Hello Kapil

    You can do one thing go to the bin folder and right click or just click on the following dlls and there is an option of Copy local which is false by default change it to true then publish the website and deploy the server this will solve your problem i hope so

    1)Microsoft.ReportViewer.WebForms.dll
    2)Microsoft.ReportViewer.Common.dll
    3)Microsoft.Web.Infrastructure.dll
    4)Microsoft.ReportViewer.Common.dll
    5)Microsoft.ReportViewer.ProcessingObjectModel.dll

    Regard's
    Raj.Trivedi
    "Sharing is Caring"

  • #751383
    Hi Kapil,

    Please make sure that you have all the reference added in the BIN folder of your application and also the path of the report is not local. I mean to say its location is not from your local system. The path must be of the server.
    Also make sure you have these references/dlls added-
    1) Microsoft.ReportViewer.WebForms.dll
    2) Microsoft.ReportViewer.Common.dll
    3) Microsoft.Web.Infrastructure.dll
    4) Microsoft.ReportViewer.Common.dll
    5) Microsoft.ReportViewer.ProcessingObjectModel.dll

    Thanks,
    Ashutosh Jha
    http://tricksroad.com


  • Sign In to post your comments